Kreol89

2015-10-29RagexeRE - Странная проблема.

36 сообщений в этой теме

где то я уже описывал по поводу sln файлов что желательно юзать ту версию на которой всё рассчитано 

eAthena-7.1.sln желателен VS7

eAthena-10.sln желателен VS10 или выше

eAthena-12.sln желателен VS12 или выше

сами себе ставите подножку!

2015 это уже другой релиз можно так сказать-))  с 2013 и 2015 это уже не малая разница даже цифры об этом говорят))

Изменено пользователем ucell-uz
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Согласен... Увидел в эмуле 14 версию, решил обновить... И сам накололся... Век живи-век учись.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 минут назад, ucell-uz сказал:

где то я уже описывал по поводу sln файлов что желательно юзать ту версию на которой всё рассчитано 

eAthena-7.1.sln желателен VS7

eAthena-10.sln желателен VS10 или выше

eAthena-12.sln желателен VS12 или выше

сами себе ставите подножку!

2015 это уже другой релиз можно так сказать-))  с 2013 и 2015 это уже не малая разница даже цифры об этом говорят))

Файлы проекта в данном случае не при чем. Добавят solution для VS2015 - будет та же проблема.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А не будет разницы в готовой сборе 13 и 14 версии?

Знаю, вопрос нюбский, но всё же

Изменено пользователем Kreol89
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всё та же проблема... Всё те же грабли...

Решил подобрать новый ехе для сервера, где квесты будут отображаться нормально, но...

Любой ехе, акромя 2015.10.29 выдаёт вот такую ошибку...

[Error]: WFIFOSET: Maximum write buffer size for client connection 4 exceeded, most likely caused by packet 0x099d (len=298, ip=127.0.0.1).

Все варианты из интернета не помогают...

Что делать я не знаю... (И  да, сам сервак я победил. Когда ставил Clan Sistem пропустил одно место в src)

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 минут назад, Kreol89 сказал:

Любой ехе, акромя 2015.10.29 выдаёт вот такую ошибку...

[Error]: WFIFOSET: Maximum write buffer size for client connection 4 exceeded, most likely caused by packet 0x099d (len=298, ip=127.0.0.1).

В какой момент получаете эту ошибку?

Дайте ссылку на архив (EXE + эмуль) для воспроизведения ошибки. 

Как появится немного свободного времени - гляну.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

При входе на чар-сервер. Exe любой кроме выше написанного. Он входит без проблем.

https://yadi.sk/d/iMLNHdKWwjZ5p

Вот, сервер и один из последних ехе.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Открываем ../src/char/char_clif.c и в функции chclif_charlist_notify меняем:

	// This is needed on RE clients from october 2015 onwards
	// If you want to use one replace false by true here
#if true && PACKETVER >= 20151001

на:

	// This is needed on RE clients from october 2015 onwards
	// If you want to use one replace false by true here
#if false && PACKETVER >= 20151001

+

В ../src/common/mmo.h для PACKETVER устанавливаем значение 20151104

В ../db/packet_db.txt для packet_db_ver устанавливаем значение 55

Сохраняем изменения и компилируем сервера(login, char, map).

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я так понимаю это для сервера rA?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо Functor! Теперь я понимаю, что все ехе, которые не RE будут вызывать такую ошибку, если оставить там значение trye?

А все ехе, которые я пробовал были обычными... Осталось найти, где скачать RE'шные ехе'шники...

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас